Infor ERP SyteLine

User Interface
Important Notices

The material contained in this publication (including any supplementary information) constitutes and contains confidential and proprietary information of Infor Global Solutions.

By gaining access to the attached, you acknowledge and agree that the material (including any modification, translation or adaptation of the material) and all copyright, trade secrets and all other right, title and interest therein, are the sole property of Infor Global Solutions and that you shall not gain right, title or interest in the material (including any modification, translation or adaptation of the material) by virtue of your review thereof other than the non-exclusive right to use the material solely in connection with and the furtherance of your license and use of software made available to your company from Infor Global Solutions pursuant to a separate agreement (“Purpose”).

In addition, by accessing the enclosed material, you acknowledge and agree that you are required to maintain such material in strict confidence and that your use of such material is limited to the Purpose described above.

Although Infor Global Solutions has taken due care to ensure that the material included in this publication is accurate and complete, Infor Global Solutions cannot warrant that the information contained in this publication is complete, does not contain typographical or other errors, or will meet your specific requirements. As such, Infor Global Solutions does not assume and hereby disclaims all liability, consequential or otherwise, for any loss or damage to any person or entity which is caused by or relates to errors or omissions in this publication (including any supplementary information), whether such errors or omissions result from negligence, accident or any other cause.

Publication Information

Release: Infor ERP SyteLine 8.02

Publication Date: September 2010
Get Additional SyteLine Training

http://KnowledgeZone.Infor.com

Get updated versions of this guide
We update our guides for new features included in new versions of the software. Additionally, we sometimes update guides to make improvements in the text or hands-on exercises. Go to the KnowledgeZone to get the latest version.

Get other training guides
The KnowledgeZone includes all the current training guides for SyteLine. Select your version of the product to see everything that’s available.

Take live instructor-led classes taught over the internet
You can take classes from expert SyteLine instructors. The classes follow the training guides, use the demo database that comes with SyteLine for hands-on exercises, and are taught over the internet so you can avoid travel. Go to the KnowledgeZone to see what’s available. The schedule is updated quarterly.

Take recorded classes at your own pace
Because the live class schedule doesn’t always match up with every user’s needs, and because many users only need to learn only a part of a full class, we’ve broken up the live classes into small pieces and recorded them. Just like the live classes, the recorded classes follow the training guides and use the demo database that comes with SyteLine for hands-on exercises. With the recordings, you will be able to watch, hear, and do exactly what you would in a live class, but do it at your own pace. Furthermore, you can focus on exactly the portion you’re interested in.
Questions?
If you have any questions or want to verify your company has an unlimited-access subscription to the KnowledgeZone, please email us at KnowledgeZone@infor.com.
# Contents

## Get Additional SyteLine Training

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>7</td>
</tr>
<tr>
<td>How to Use This Manual</td>
<td>8</td>
</tr>
<tr>
<td>Principles of Successful Learning</td>
<td>8</td>
</tr>
<tr>
<td>Manual Section Structure</td>
<td>10</td>
</tr>
<tr>
<td>Feedback</td>
<td>10</td>
</tr>
<tr>
<td>SyteLine Navigation Helps</td>
<td>11</td>
</tr>
<tr>
<td>SyteLine Shortcut Keys</td>
<td>11</td>
</tr>
<tr>
<td>SyteLine's Power Bar</td>
<td>12</td>
</tr>
<tr>
<td>Navigation for this Course</td>
<td>14</td>
</tr>
<tr>
<td>Course Objectives &amp; Prerequisites</td>
<td>15</td>
</tr>
<tr>
<td>Objectives of This Course</td>
<td>15</td>
</tr>
<tr>
<td>Prerequisite Courses</td>
<td>15</td>
</tr>
<tr>
<td>Note to the Instructor</td>
<td>15</td>
</tr>
</tbody>
</table>

## Section 1: How to view data

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>18</td>
</tr>
<tr>
<td>Key points</td>
<td>18</td>
</tr>
<tr>
<td>Forms</td>
<td>18</td>
</tr>
<tr>
<td>Records</td>
<td>18</td>
</tr>
<tr>
<td>Fields</td>
<td>18</td>
</tr>
<tr>
<td>Collections</td>
<td>18</td>
</tr>
<tr>
<td>Using the Master Explorer to find forms</td>
<td>19</td>
</tr>
<tr>
<td>Key points</td>
<td>19</td>
</tr>
<tr>
<td>Module and Role Trees</td>
<td>19</td>
</tr>
<tr>
<td>Navigation Pane Buttons</td>
<td>20</td>
</tr>
<tr>
<td>Navigation Pane Menu</td>
<td>20</td>
</tr>
<tr>
<td>Using the All Forms folder to find forms</td>
<td>21</td>
</tr>
<tr>
<td>Key points</td>
<td>21</td>
</tr>
<tr>
<td>Form</td>
<td>21</td>
</tr>
<tr>
<td>Using Select Form to find forms</td>
<td>22</td>
</tr>
<tr>
<td>Key points</td>
<td>22</td>
</tr>
<tr>
<td>Form &amp; fields</td>
<td>22</td>
</tr>
<tr>
<td>What are the form modes?</td>
<td>23</td>
</tr>
<tr>
<td>Key points</td>
<td>23</td>
</tr>
<tr>
<td>Filter mode</td>
<td>23</td>
</tr>
<tr>
<td>Refresh mode</td>
<td>24</td>
</tr>
<tr>
<td>New mode</td>
<td>25</td>
</tr>
<tr>
<td>Practice: find forms</td>
<td>26</td>
</tr>
<tr>
<td>Using linking features to find forms</td>
<td>27</td>
</tr>
<tr>
<td>Key points</td>
<td>27</td>
</tr>
<tr>
<td>Linking buttons</td>
<td>27</td>
</tr>
<tr>
<td>Edit menu links</td>
<td>28</td>
</tr>
<tr>
<td>Actions menu lists</td>
<td>29</td>
</tr>
<tr>
<td>Practice: link to forms</td>
<td>31</td>
</tr>
<tr>
<td>What are the form views?</td>
<td>32</td>
</tr>
<tr>
<td>Key points</td>
<td>32</td>
</tr>
<tr>
<td>Dual view</td>
<td>32</td>
</tr>
<tr>
<td>Detail view</td>
<td>33</td>
</tr>
<tr>
<td>Grid view</td>
<td>33</td>
</tr>
<tr>
<td>Adjusting grid columns</td>
<td>34</td>
</tr>
<tr>
<td>Practice: use query to filter</td>
<td>42</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----</td>
</tr>
<tr>
<td>Key points</td>
<td>43</td>
</tr>
<tr>
<td>Procedure</td>
<td>43</td>
</tr>
<tr>
<td>Saving a query</td>
<td>46</td>
</tr>
<tr>
<td>Applying a saved query</td>
<td>47</td>
</tr>
<tr>
<td>Setting up a filter prompt</td>
<td>47</td>
</tr>
<tr>
<td>Pre-defined Queries</td>
<td>48</td>
</tr>
<tr>
<td>Using CurDate ( ) in Queries</td>
<td>49</td>
</tr>
<tr>
<td>Practice: use query to filter</td>
<td>50</td>
</tr>
<tr>
<td>Printing the current record or collection</td>
<td>51</td>
</tr>
<tr>
<td>Key Points</td>
<td>51</td>
</tr>
<tr>
<td>Print Preview</td>
<td>51</td>
</tr>
<tr>
<td>Practice: print out record</td>
<td>52</td>
</tr>
<tr>
<td>Viewing and printing simple graphs of data</td>
<td>53</td>
</tr>
<tr>
<td>Key points</td>
<td>53</td>
</tr>
<tr>
<td>Procedure</td>
<td>53</td>
</tr>
<tr>
<td>Example</td>
<td>54</td>
</tr>
</tbody>
</table>

**Section 2: How to work with the data** .............................. 55

<table>
<thead>
<tr>
<th>Editing data in a collection</th>
<th>56</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding records</td>
<td>57</td>
</tr>
<tr>
<td>Finding and adding values in a drop-down list field</td>
<td>58</td>
</tr>
<tr>
<td>Key points</td>
<td>58</td>
</tr>
<tr>
<td>Using the Find menu option</td>
<td>58</td>
</tr>
<tr>
<td>Filtering a drop-down list</td>
<td>59</td>
</tr>
<tr>
<td>Using the Add menu option</td>
<td>59</td>
</tr>
<tr>
<td>Copying records</td>
<td>60</td>
</tr>
<tr>
<td>Checking for errors</td>
<td>61</td>
</tr>
<tr>
<td>Key points</td>
<td>61</td>
</tr>
<tr>
<td>Correcting Errors</td>
<td>61</td>
</tr>
<tr>
<td>Deleting records</td>
<td>62</td>
</tr>
<tr>
<td>Deleting a single record</td>
<td>62</td>
</tr>
<tr>
<td>Deleting a range of records</td>
<td>62</td>
</tr>
<tr>
<td>Undoing changes</td>
<td>63</td>
</tr>
<tr>
<td>Saving records</td>
<td>64</td>
</tr>
<tr>
<td>Saving a single record in your collection</td>
<td>64</td>
</tr>
<tr>
<td>Saving all records in your collection</td>
<td>64</td>
</tr>
<tr>
<td>Practice: data entry</td>
<td>65</td>
</tr>
</tbody>
</table>
Contents

Finding and replacing values in a range of records ................................................................. 66
   Key points ............................................................................................................................. 66
   Replace ................................................................................................................................. 66
Practice: update a field on a range of records ........................................................................ 68
Notes Overview ...................................................................................................................... 69
   Key points ............................................................................................................................. 69
   Note types ............................................................................................................................ 69
   Reusable Notes .................................................................................................................... 70
   Internal/External Notes ........................................................................................................ 70
   Printing Notes on Reports .................................................................................................. 70
Creating notes for the current record ..................................................................................... 71
Creating reusable notes ......................................................................................................... 72
Practice: create notes ............................................................................................................. 73
Printing reports ...................................................................................................................... 74
   Key points ............................................................................................................................. 74
   Sample form ......................................................................................................................... 74
   How to define whether you print or save the report ........................................................... 75
Practice: print a report .......................................................................................................... 76
Running activities and utilities ............................................................................................. 77
   Key points ............................................................................................................................. 77
   Samples ................................................................................................................................. 77
   How to verify the process was successful .......................................................................... 78
Practice: run an activity ......................................................................................................... 79
Exporting a file ...................................................................................................................... 80
   Key Points ............................................................................................................................ 80
   Form & fields ......................................................................................................................... 80
Moving data to and from Excel .............................................................................................. 82
   Key points ............................................................................................................................. 82
   Copying an entire collection ............................................................................................... 82
   Copying selected records .................................................................................................... 83
   Copying selected columns ................................................................................................. 83
   Copying selected cells ........................................................................................................ 84
   Notes on copying ................................................................................................................. 85
   Pasting from a spreadsheet into a collection grid .............................................................. 86
Practice: export to and from Excel ........................................................................................ 89
Section 3: How to set up basic personalizations ................................................................. 91
How to create a personal menu ............................................................................................. 92
   Key points ............................................................................................................................. 92
   Procedure ............................................................................................................................. 92
Practice: create a personal menu .......................................................................................... 93
How to set up SyteLine to open forms when you login ......................................................... 94
   Key points ............................................................................................................................. 94
   Procedure ............................................................................................................................. 94
Practice: set forms to automatically open ............................................................................ 95
How to set up SyteLine to open sets of forms with custom size and positioning ..................... 96
   Key points ............................................................................................................................. 96
   Procedure ............................................................................................................................. 96
Practice: create a workspace ................................................................................................. 98
How to set cap size on records retrieved .............................................................................. 99
   Key points ............................................................................................................................. 99
   Settings ................................................................................................................................. 99
How To Setup Up Tabs ...................................................................................................... 100
   Example .............................................................................................................................. 100

© 2010 Infor, Inc. SyteLine User Interface Training Guide 5
Contents

Turning on Tabbed View ................................................................. 101
Image Tooltip .............................................................................. 101
How to change the mode the form opens in ................................... 102
  Key points .............................................................................. 102
  Procedure ............................................................................. 102
What are other personalization options? ....................................... 103
Wrap up: make job aids ............................................................... 104
Preface
How to Use This Manual

This manual was written with the intent to guide the student through the four parts of this standard training model:

1. Introduce the topic.
2. Walk the students through a simplified version of the process or concepts they need to learn to give them their bearings.
3. Provide the student with exercises that help them discover the topic in depth.
4. Wrap up the topic.

Each part of the training model is important, but the heart of this method revolves around two learning principles that the student and teacher must keep in mind. These principles are: (1) We learn how to do a thing by doing it, and (2) we need to learn both the details and the big picture, both application and concept.

This means the students need to perform detail and big picture activities to learn this material. Just listening and understanding is not enough. You can read more about what detailed and big picture activities are in the section on principles for successful learning.

Now, no course can make anyone an expert. But the more the instructor helps the students through the activities that help them learn, the more the course will help the student down the road of expertise.

Principles of Successful Learning

The training model above applies learning principles. But is that everything the student and instructor do to make sure the maximum amount of learning takes place? That's a topic for a whole book, if not a series. But we can summarize much of that by realizing that learning is a biological process.

Your Brain Is Not a Computer

Our brain is more like a muscle than a computer. Learning is not something we store in a file; it's something we grow. Just because we see, hear, or even do something doesn't mean we'll remember it. We must exercise our learning consistently. If we only work out during class, we're going to develop our learning like weekend warriors develop their stamina. Here are a few powerful things you can do grow your learning before and after class.

BEFORE

- Get into SyteLine and become familiar with the areas you will be working in during the course.
- Read SyteLine manual and passages from texts related to the business topics.
- Answer and preparation questions your instructor might have given you.
- Write up your own questions.

AFTER

- Right after class-create quick review & recall notes
- Next day-perform detail and big picture activities
- Next week-perform detail and big picture activities
- Next month-perform detail and big picture activities
Detail & Big Picture Activities
In each of our classes you perform detail and big picture activities. These activities constitute a workout. Your learning will grow through these activities, but just as with muscles, working out once won't produce long-lasting effects. You need to work your neural paths again. When you perform detail and big picture activities you're working out again. Not only will these activities reinforce what you've learned, they will often help you understand more.

Big picture activities help you summarize and see relationships between the details of a topic. They help you create a pattern to fit information into. Big picture activities include things like creating mind maps, process flows, relationship diagrams, and outlines.

Detail activities help you understand navigation, specific fields, the effect of various parameters, and the steps of each business process---they require you to get into the system. Detail activities include things like setting up a BOM, taking a customer order and shipping it, running reports, and tracing accounting.

Again, the first post-class workout you will want to perform is clarifying and consolidating your notes. You will forget. But you can drastically cut the amount you forget and your recall work by taking 10 minutes to create clear notes.

Learning is Growth
A number of studies have confirmed the idea that learning is a biological growth process that requires repetition.

RECALL
A number of studies have found that:

• Without review, people forget between 46% to 80% of what they've learned within 24 hours
• When tested six weeks after a class, students who took a 5-minute review test after their class recalled one and a half times more than the students who had no review test immediately after class.
• People learn and recall more when they: (1) structure what they've learned in their own words, (2) recite their learning, and (3) distribute practice over many periods versus doing it all at once.

BREAKS
Studies have also shown that people recall more if they take breaks every 20-50 minutes. Psychologists believe that it takes neural traces from about five seconds to 15 minutes to jell or consolidate. This is how they explain topics becoming clear during a break or immediately upon returning and why we recall more immediately after a learning period than at the end of a learning period.

We really do need to let information "sink in."
Manual Section Structure
This manual applies the learning principles and the training model explained above. Each major topic should have 3 parts to it--an (1) Introduction, (2) Discovery, and (3) Wrap Up.

<table>
<thead>
<tr>
<th>Section Part</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>A presentation or activity to give students the big picture about what they're about to learn.</td>
</tr>
</tbody>
</table>
| Discovery    | Demonstrations  
A step-by-step guide through the topic. Usually the instructor guides the class through each step.  
Reference  
Explanation of the key concepts, forms, fields, and processes of the topic. Teachers will draw your attention to key concepts in their introduction and the guided practice, but they may not cover every item in these sections.  
Exercises  
Opportunity for the students to explore and practice. These exercises are either in the guide or in an accompanying workshop guide. |
| Wrap Up      | An exercise that helps the student structure their knowledge. The wrap-ups usually take the form of a list of key discussion questions or a mind map. In both cases, the teacher will lead the class through the wrap up.  
A mind map is a method for taking notes that allows you to show connections between various concepts. |

It will be the teacher's responsibility to adapt this manual to each audience by adding or taking away from what is found.

Feedback
Please send any feedback you have on this guide and course to KnowledgeZone@Infor.com.
## SyteLine Navigation Helps

### Syteline Shortcut Keys

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>NAVIGATING FORMS</strong></td>
<td></td>
</tr>
<tr>
<td>Ctrl + F4</td>
<td>Close current form</td>
</tr>
<tr>
<td>Ctrl + o</td>
<td>Open Select Form</td>
</tr>
<tr>
<td>Ctrl + w</td>
<td>Open workspaces</td>
</tr>
<tr>
<td>Ctrl + TAB</td>
<td>Switch view to next open form</td>
</tr>
<tr>
<td><strong>NAVIGATING RECORDS</strong></td>
<td></td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>Move to first editable field of form</td>
</tr>
<tr>
<td>TAB</td>
<td>Move to the next field</td>
</tr>
<tr>
<td>F8</td>
<td>Move to the next record</td>
</tr>
<tr>
<td>Alt + TAB</td>
<td>Move to the previous field</td>
</tr>
<tr>
<td>F7</td>
<td>Move to the previous record</td>
</tr>
<tr>
<td>Ctrl + F8</td>
<td>Retrieve next collection of records</td>
</tr>
<tr>
<td>Ctrl + 2</td>
<td>Toggle between dual view and form only view</td>
</tr>
<tr>
<td>Ctrl + 1</td>
<td>Toggle between dual view and grid only view</td>
</tr>
<tr>
<td>F6</td>
<td>Toggle cursor focus between grid and form</td>
</tr>
<tr>
<td><strong>EDITING RECORDS</strong></td>
<td></td>
</tr>
<tr>
<td>F2</td>
<td>Activate drop down field</td>
</tr>
<tr>
<td>Ctrl + n</td>
<td>Add new record record</td>
</tr>
<tr>
<td>Ctrl + a</td>
<td>Add value for current field</td>
</tr>
<tr>
<td>Ctrl + c</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl + x</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl + d</td>
<td>Delete record</td>
</tr>
<tr>
<td>Ctrl + l</td>
<td>Display details for value in current field</td>
</tr>
<tr>
<td>Ctrl + f</td>
<td>Find value for current field</td>
</tr>
<tr>
<td>Ctrl + v</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl + s</td>
<td>Save changes</td>
</tr>
<tr>
<td>Ctrl + z</td>
<td>Undo</td>
</tr>
<tr>
<td><strong>FILTERING RECORDS</strong></td>
<td></td>
</tr>
<tr>
<td>F3</td>
<td>Cancel filter in place and return to</td>
</tr>
<tr>
<td>Ctrl + q</td>
<td>Open query form</td>
</tr>
<tr>
<td>F5</td>
<td>Refresh all records in the collection</td>
</tr>
<tr>
<td>Ctrl + F5</td>
<td>Refresh only the record selected</td>
</tr>
<tr>
<td>Ctrl + F2</td>
<td>Repeat find</td>
</tr>
<tr>
<td>F4</td>
<td>Set form in Filter in Place mode / Run Filter in Place to retrieve data</td>
</tr>
<tr>
<td><strong>OTHER</strong></td>
<td></td>
</tr>
<tr>
<td>F1</td>
<td>Open field level help topic</td>
</tr>
<tr>
<td>Ctrl + p</td>
<td>Print</td>
</tr>
<tr>
<td>Ctrl + e</td>
<td>Toggle design mode on and off</td>
</tr>
</tbody>
</table>
**SyteLine’s Power Bar**

**Left side**

- Open a form
- Save record
- Save record then Close the form
- Cancel modifications then Close the form
- Add new record
- Delete record
- Cancel all unsaved modifications in collection then Refresh collection
- Cancel unsaved modifications in current record then Refresh current record
- Filter in Place
  - Move to first, previous, next, or last record in collection
Right side

Find value for highlighted field
Add value to selection for highlighted field
Details for highlighted field
Notes for current record - Empty
Notes for current record - Has notes associated
Export collection to Excel
Open Help about the form
Enter or Exit form design mode
Save form design, regenerate, and open
Go to Queries folder
Go to Activities folder
Go to Utilities folder
Go to Maintenance folder
Go to Files folder
Go to Reports folder

The Help Tip displays in the lower left hand corner of the application (Status bar) even when your selection is not active.
Required, System-generated and Read-only Fields

Any field that is required for a window will have a yellow background. A green background indicates a system-generated field, and a gray background is read-only.

Standard GUI fields

- **Check box indicating YES or NO**
  - Control Point

- **Radio button to select one option from multiple choices**
  - Labor Hours per Piece
  - Pieces per Labor Hour

- **Drop-down box to select one option from multiple choices**
  - Backflush: Labor

Navigation for this Course

SyteLine groups navigation for data, process, and report forms by business function. Therefore, you'll minimize the time it takes for you to get your bearings, if you (1) identify the major functions covered in this course, and (2) identify which data, process, and report forms are grouped into that function.
Course Objectives & Prerequisites

Objectives of This Course
After successfully completing this course, the student should be able to:

• Find forms
• View data
• Link from one form to another
• Add, update, & delete records
• Create notes
• Set up preferences
• Export and import data to other programs

Prerequisite Courses
This class was developed with the assumption that the student knows the material from the classes listed below. If a student does not know the information in these classes, he or she will find this class moves too quickly.

• There are no prerequisites for this class.

Note to the Instructor
You are responsible for selecting the topics and activities that meet the needs of your students. Depending on your class, you may not be able to cover all the material in this manual in one day. Make sure you talk to your students when planning the class and carefully select the topics you want to cover.

Make sure you assess the speed of the class half way through and then make any necessary adjustments so you cover what you and your students have determined has the highest priority.

The exercises for this class have been designed to generate discussion and student involvement. Many of the exercises do not have "check" figures. You are to provide that feedback by doing the exercises along with the students. Then they can check their answers against yours.

We caution you not to substitute lectures and presentations for the exercises. Students will learn the most while doing the exercises. A good time ratio for lecture to student work is 30%:70%.

Consider using the review exercises found in the appendix as part of your end of class wrap up.
Section 1: How to view data
Introduction

Key points
When working with SyteLine, you will be working with: Forms, Records, Fields, and Collections. Because of this, you’ll need to know how each works.

Forms
Almost everything you do in SyteLine happens through the interface of a form. A form is a window through which you work with the data in the SyteLine database. Looking up information, entering new information, and generating reports are typical interactions.

For example, when you enter a purchase order, you’ll enter it via a form. When you want to check on the status of a purchase order, you’ll open the same form. However, when you want to record the receipt of items on a purchase order, you’ll open a different form.

So the very first thing to learn is how to find the form that will allow you to do what you want to do.

There are four ways to find and open forms in SyteLine:
• Search for the form using the Master Explorer module or role trees
• Search for the form using All Forms folder of the Master Explorer
• Search for the form using Select Form
• Use linking features
You’ll learn how to use each of these methods in this section.

Records
Everything you do in a form relates to one or more records in the database. A record is a group of related pieces of data or information.

For example, a record for item SPX-90 would contain all of the information related to that item. A record for customer order 1001 contains all the information for that specific order. A record for employee Mary Salazar contains all the information for that employee.

Fields
Every record is made up of a number of fields. Each field displays a particular bit of information that’s part of the record.

For example, the record of a journal entry would include fields for the account number, the amount charged to the account, whether the amount is a credit or a debit, the transaction date, etc. The record of an item would fields for item’s SKU, description, unit of measure, cost type, etc.

Collections
Forms can display many records. A group of related records is called a collection. With many forms, it is possible to view collections of all available records. But, in practice, you typically work with a specific subset of records in a particular collection.

For example, you can open the customer order form to see all orders related to a specific customer, or all the customers in a specific area, or all the customers with a particular status. Each one of these is a collection of customer orders.

In this section, you’ll learn how to retrieve collections from the database that match your specific criteria.
Using the Master Explorer to find forms

Key points

Notice that the Master Explorer is set up like Windows Explorer. Clicking on folders in the left pane will show their contents in the right pane.

In the right pane, double clicking folders or pressing Enter will open the highlighted folder. The same actions will open a highlighted form.

If you ever close the Explorer and want to open it again, select View \ Explorer.

The Explorer has two panes. Use the top (Tree) pane to expand folders and open forms. Click the buttons in the lower (Buttons) pane to display different trees in the current folder level. You can customize the Explorer buttons and tree view to show only certain modules, and you can customize which buttons display, and in what order.

Explorer folders include an image, to make it easier to recognize certain types of forms. You can customize these images.

You can use the right-click menu to add shortcuts to forms in appropriate Explorer folders. You can specify parameters and descriptions for the shortcuts. For example, you can define parameters that filter the form data when opening the form by the shortcut. If you define a description for a shortcut, then that description displays as a tooltip when you hover over the shortcut in the Explorer.

You can also use the right-click menu to add workspace shortcuts in an appropriate Explorer folder. You can define a name and description for the shortcut.

Module and Role Trees

The master explorer groups the forms in two different ways: one is by module, the other is by role. Both views contain ALL of the same forms and can be expanded as a tree.
Navigation Pane Buttons

The bottom of the navigation pane is to provide buttons that represent folders found in the currently selected folder. By clicking on the button, the user will view the explorer object tree defined for that folder.

Navigation Pane Menu

Users can also alter the list of buttons on the navigation pane via its options.

A system administrator can remove or hide folders and subfolders for individuals or groups of individuals, so two users may see different things in their master explorer trees.
Using the All Forms folder to find forms

**Key points**

Part of the Master Explorer is the All Forms folder. It contain exactly what it says. If you don't know where the form is in the module/process folder structure, you can simply click on this folder, then begin typing the name of the form in the right pane.
Using Select Form to find forms

Key points
This tool works much like the All Forms folder but gives you more flexibility.

Form & fields

Form \ Open

Select by Name Instead of Caption?
You can select whether you want to use the name (name of the form used in the code) or the caption (the name you see on the top left of each form). In almost all cases the only difference is that the name is hungarianized. However, some form like Scheduling Shifts (caption) have a different name.

To find out the name of a form, highlight that form in the Explorer, then select Edit \ Properties.

Place cursor in the top part of the form and begin typing the form you're looking for. You can use the arrow keys to move up and down. Press the Enter key or double click the name to open the form.

Filter
If you don’t know the form’s exact name but know a word it contains, you can use the filter fields and button to display only those forms that have that term in them.

After using the filter, if you want to return all the forms again, simply delete all values from the All Containing field and click the Filter button.
What are the form modes?

**Key points**

SyteLine forms have three modes:

- Filter—enter filter criteria
- Refresh—view and modify data
- New—enter a new record

You must be in Refresh mode to enter or update records. Your system administrator can set a form to open by default in any one of these three modes.

**Filter mode**

You know you’re in filter mode when all the fields are blank. You’ll learn about how to filter in a later.

You CANNOT do anything in this mode but enter filter criteria.

If you’re in filter mode and want to get to refresh mode simply run the filter (with or without filter criteria) by pressing the F4 key or selecting Actions \ Filter \ Begin In Place.
Section 1: How to view data

Refresh mode

Master Explorer \ Material \ Product Definition \ Current Operations
You know you’re in this mode when you see data in the fields on both the form and grid view. You’ll also see required fields highlighted in yellow.

NOTE
You CAN add, update, or delete when you’re in refresh mode.
New mode

Master Explorer \ Material \ Product Definition \ Current Operations

New mode looks a lot like refresh mode, however, you can tell you’re in new mode by looking at the left column of the grid for the current record. There will be a "n" on the new record. You’ll see a "m" for records you’ve modified and a "d" for those you’ve selected to be deleted.
Practice: find forms

Try to use all three methods --Master Explorer, All Forms folder, and the Select Form feature--to you find the forms below.

1. Find these forms:
   - Order Shipping.
   - Purchase Orders.
   - Job Orders.
   - Invoices.

2. What’s the business area you usually work in? Open that folder and note the various forms found there.

3. What’s an process or report you often run? Find the form for it.

4. Look at the listing of Shortcut Keys and Hotbar buttons in the preface. Identify those you could use to perform the tasks learned in this section.
Using linking features to find forms

**Key points**
When you’re on a form, you may have one or more these features that will let you link to other related forms:

- Buttons linking to another form
- Edit menu links
- List displays under the Action menu

**Linking buttons**
If you click on the Stock Loc button on the Items form, the system will open the Item Stockroom Locations form. Notice the caption says “Linked.” This means the originating drives the data displayed in the linked form. If you select another record in the originating form, the linked form will update to show only data associated with that record.
**Edit menu links**

Many forms have fields that use values you set up on another form. For example, the Items form uses unit of measures. You set up unit of measures on another form. But you can link to that form to find a specific unit of measure, add a new one, or see the details of the one currently in the field. If you add or find, when you close the form, the system will ask you if you want to use that record for the originating record as shown below.

![Edit menu links](image)

**Edit \ Find Value, Add Value, or Details for Current field**

You can also select these edit values by right-clicking on a field supported by values maintained in another form.
**Actions menu lists**

Sometimes you want to see data associated with the current record on the form. Many forms have lists that show such data under the Actions menu.

For example, if you want to see the BOM of the current record in the Items form, select Actions \ List BOM

**Actions menu**

![Actions menu image](image)

**Actions \ List Routing BOM**
Some of the list forms look like other forms that exist in the system, but are read only. Sometimes they open up a linked form like linking buttons do.
Practice: link to forms

1. Find the purchase orders form.
2. Select the List Receipts option from on the Actions menu.
3. Link to the purchase order lines.
4. View the vendor for any line using the Details for Current Field function.
What are the form views?

**Key points**

All of the master record forms have two views:

- Grid (right side, 2nd splitter pane)
- Detail (left side, 1st splitter pane)

All the fields shown in the detail view, except for those contained in a sub-grid, are displayed in the grid view. The grid view, however, does not contain the button founds on the form view. Anything you enter in one view is entered in the other view.

You can toggle between the views by selecting the Hide/Show splitter pane options in the View menu.

**Dual view**

This is the default view of a form and shows both the grid and detail view.
Section 1: How to view data

Detail view

Select Hide/Show 1st Splitter Pane from the View menu to toggle to and from the detail view.

Grid view

Select Hide/Show 2nd Splitter Pane from the View menu to toggle to and from the grid view.
Adjusting grid columns

**Key Points**

You can make these adjustments to the columns in the grid:

- Resize column width
- Change the column order
- Hide column

If you have rights, the system will save these settings for you when you close the form.

**Resizing columns**

To resize columns, hover over the right border of the column heading. Your arrow will change as shown in the screen shot. When it does, click and drag the column margin to make it wider or more narrow.

**Changing the column order**

To change the column order:

1. Open the Edit Grid Column Visibility and Order form by right-clicking on the left-most column in the grid which displays the record row numbers and selecting Edit Grid Columns.

2. Select the column you want to move. You can select multiple columns using the CTRL key. You can select a range of columns using the SHIFT. Press and hold the desired key while using your mouse to select the columns.

3. Use the Up and Down buttons to change the order in which the column(s) will appear.

4. Click the OK button
Hiding columns
To hide columns:

1. Open the Edit Grid Column Visibility and Order form by right-clicking on the left-most column in the grid which displays the record row numbers and selecting Edit Grid Columns.

2. Deselect the Visible checkbox of the column you want to hide. You can use the Show All and Hide All buttons to select and deselect all the checkboxes.

3. Click the OK button.
Practice: adjust grid columns

1. Open the Planning Detail form.
2. Switch it to grid view.
3. Hide the Select field column.
4. Move the Exception Message field column so it appears as the sixth column.
5. If the form is in Filter mode, press the F4 key to retrieve data.
6. Resize the Item, Date, & Projected On Hand columns to fit the data.
Sorting records

Key points
There are two ways to sort:

• If you’re in grid view, double-click the column heading to sort in ascending order. Double-click again to sort in descending order.
• In either grid or detail view, use the Sort form.

Sort form

Edit menu \ Sort Collection

Collection
The form you want to sort

By Property
The field you want to sort on

Descending
Select to sort in descending order; deselect to sort in ascending order.

Please note: some fields that appear to be numeric (for example, Account) might actually be character-based. Thus, they would use text-character sort order. In text-character (ascending) order:

• Character strings are generally sorted from left to right. That is, the first character (furthest left) is evaluated, then the second, and so on.
• A blank field comes before any other character. Thus, any blank fields always display first.
• Special characters might come before numerals, between numerals and letters, or after letters. Thus, #222 comes before 222, but @201 comes after 222.
• Numerals display in correct numeric order, regardless of size.
• Numerals display before alphabetic characters.
• Upper-case characters display before lower-case characters. Thus, XL-64 comes before xl-64.

For example, if you attempt an ascending sort by account number, the following accounts would be sorted in this order:

1. (blank field)
2. #222
3. 222
4. 2220
Case-sensitive

When selected, records are sorted in ascending order so that records that begin with uppercase letters display before records that begin with lowercase letters. When cleared, the sorting routine ignores capitalization.

For example, suppose you have three records for customers, whose business names are Electronic Commerce, Ltd., eMall, Inc., and Endzone. If you select this check box, they would be sorted as follows (in normal, ascending, order):

- Electronic Commerce, Ltd.
- Endzone
- eMall, Inc.

If you clear this check box, they would be sorted as follows:

- Electronic Commerce, Ltd.
- eMall, Inc.
- Endzone
Introduction to filtering

SyteLine is built on three levels: the database, middleware, and presentation layer.

You copy (this is often called "refresh" or "retrieve") data from the database and hold it in the form (what you do with that data will not affect the data in the database until you save).

You probably don’t want to refresh all of the records associated with a given form. SyteLine does have a setting that lets you specify how many records you can copy at any one time; it’s a cap you can specify in the Options menu. However, that only affects the number of records you’ll copy. What about the nature of the records you want to work with? SyteLine provides two ways to filter the data so you can retrieve exactly what you want:

• Filter in place
• Query

Once you have the data, you can sort it by any field.

If you don’t like the changes you’ve made to the data, you can re-copy the data from the database, overwriting your changes, using the refresh features.
Using filter in place

**Key points**
When you activate Filter-in-Place, any collection currently associated with the form is cleared and fields on the form become blank. You can then specify filter criteria in the fields and retrieve a collection of records that meet those criteria.

Records matching your criteria are displayed in the form. If no records meet the criteria, the form is placed in New mode. If you leave all fields blank, the system retrieves all records up to the current cap on data records because the collection is unfiltered.

The number of records retrieved is limited to the current cap on data records.

Filter-in-Place does not support the logical operators AND and OR. If you need to specify multiple criteria for one field, use the query form associated with your form.

**Filter Options**
Use these operators on as many fields as you wish to define your filter:
- Wildcard: * (you can change this default value)
- Greater than: >
- Less than: <
- Not equal to: <>
  - Not equal to null: <>null

You can filter for deselected checkboxes by first selecting the checkbox and then deselecting it. Until you select the checkbox in filter mode, the system does not recognize checkbox filter criteria.

**Examples**
Suppose you want to find all vendors whose ZIP code begins with 432. On your vendor-information form, specify "432*" in the ZIP code field. The system retrieves a collection of records for vendors with ZIP codes such as 43215 and 43206.

Suppose you want to find each vendor whose ZIP code is less than 43215. In the ZIP code field, specify "< 43215." The retrieved collection consists of records for vendors with ZIP codes such as 21075, 10292, and 02101.

Suppose that you want to retrieve only records that have data in a specific field. You would type in "<>null".

**Starting, running, and clearing filter criteria**

| To...                                                      | Use this..          | By pressing this key...
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Get to the filter view</td>
<td>Begin in place</td>
<td>F4</td>
</tr>
<tr>
<td>Run the filter</td>
<td>Execute in place</td>
<td>F4</td>
</tr>
<tr>
<td>Cancel a filter you’re building and go back to the previous collection</td>
<td>Cancel in place</td>
<td>F3</td>
</tr>
<tr>
<td>Clear all the current filter criteria while in filter view</td>
<td>Clear in place</td>
<td>F5</td>
</tr>
</tbody>
</table>
**Procedure**

1. Open a form.
2. Activate Filter-in-Place mode by any of the following means:
   - Press F4.
   - Click on the toolbar filter button.
   - On the Actions menu, point to Filter. Then click Begin in Place.
3. Enter a value in one or more fields to specify criteria for the records you want to retrieve.
4. Execute Filter-in-Place by performing one of the following actions:
   - Press F4 again.
   - Click on the toolbar filter button.
   - On the Actions menu, point to Filter. Then click Execute in Place.
Practice: use filter in place

Review the listing of Shortcut Keys and Hotbar buttons in the preface. Identify those you could use to perform the tasks learned in this section.

1. Open the Item Stockroom Locations form and start filter in place.
2. Type FA* in the item field. Execute filter in place.
   a. How many entries were returned? ______________
   b. How many FA-10000 records were found? ______
   c. Specify how many were specifically for Main. _____
Using a query

Key points
Most forms have a corresponding query form. Use queries for more complex filtering. If you want to use the query filter over and over, save it before you click OK and return the dataset.

Procedure

1. With a form open, on the Actions menu, point to Filter, and click By Query. Or right-click outside a field, point to Filter, and click By Query. Or press CTRL+Q. (In forms that are not associated with a query form, the By Query menu command is unavailable.)

2. Specify any primary criteria for your search.

3. Specify any additional criteria.

4. Click Refresh to preview the search results.

5. Click OK to return all records found in the search to the main form.

How to select primary criteria
On the Primary Criteria tab on a query form, you can specify query criteria for the principal fields in the form to which the query form is related. For example, in a form used to maintain information about customers, primary fields might include customer identification number and customer name. The tab on the related query form provides criteria-specification boxes for the principal fields. The same fields are also listed on the Additional Criteria tab; query criteria for the fields can be specified on both tabs.

Primary criteria consist of an operator for a field on which you wish to filter data and a value for the field. Suppose you wish to retrieve all records that contain "accounts payable" in the Description field. In the example below, the operator for the Description field is like. The value "accounts payable" restricts records to those containing "accounts payable" in the field. (The wildcard character ** matches all characters.) Because no value is specified for the Name field, the field can contain any value. The query returns records containing "Accounts Payable Group" and "MGR - Accounts Payable Group" in the Description field.

Primary criteria are joined by AND. That is, records are retrieved from the database only if they meet all the criteria.

To specify primary criteria
1. In a query form, select the Primary Criteria tab.
2. For a field on which you wish to filter, select an operator.
3. Enter a value for the field.
   - You can use the wildcard to match unspecified characters.
   - You can enter the Null keyword to find records containing a null value in the field; the operator must be Equal (=). To find records in which the field is not null, use the Null keyword with the Not Equal (<> ) operator.
4. Repeat steps 2 and 3 if you wish to filter on more than one field.
5. Click Refresh to preview the results in the Results pane.

**How to select secondary criteria**

On the Additional Criteria tab of a query form, you can specify criteria for any of the fields on the primary form. The tab includes fields that are listed on the Primary Criteria tab. You do not have to specify primary criteria before you specify additional criteria.

Query criteria are made up of query clauses. A query clause consists of a field name, an operator, and a value. For example, to retrieve records for vendors located in New York, you would create a clause similar to State = ‘NY’ , where “State” is a field name on the primary form in which vendors are defined in your system; “=” is an operator specifying identity; and “NY” is the code value assigned to New York in your system.

You can create multiple clauses and join them by AND or OR. Clauses joined by AND retrieve only those records that meet the criteria specified in each of the clauses. Clauses joined by OR retrieve records that meet any one of the criteria.

To specify additional criteria

1. In a query form, select the Additional Criteria tab.
2. In the first drop-down box, select a field on which you want to filter.
3. In the second drop-down box, select an operator.
4. In the third drop-down box, enter a value.
   - You can use the wildcard character to match unspecified characters.
• You can enter the Null keyword to find records containing a null value in the field; the operator must be Equal (=). To find records in which the field is not null, use the Null keyword with the Not Equal (<> ) operator.

5. Specify whether to join the current query clause with any previous clause by AND or OR. To use OR, select the check box OR instead of AND with previous clause. To use AND, clear the check box.
   • If the current clause is the first clause you have specified in the query form, accept the default AND.
   • If you specified primary criteria, be sure to select AND or OR according to how you want to join the current clause with the primary criteria.

6. Click Add. The clause is added to the list at the foot of the form. The letter N may appear between the operator and the value in the clause, indicating that the system is using Unicode (double-byte) character codes.

7. Repeat steps 2-6 for each additional clause. To remove a clause, select it in the list and click Remove.

8. You can preview records retrieved by the query or you can return the retrieved records to the parent form.
   • To preview records, click Refresh. Records appear in the Results grid.
   • To return the records to the parent form, click OK.
Section 1: How to view data

**Saving a query**

Applying filters that have generated desired results can save time and give results to FAQ's. This will work on all Query Forms and Ctrl + Q queries.

![Items Query](image)

**Actions Menu + Filter + Save**

Whether you use Ctrl + Q or the `<Form name>Query Form you can save the Filter Criteria with an assigned name to use at a later date.

- **Primary Criteria** - A first pass using one line of filtering criteria-Main or key criteria, like customer.

- **Additional Criteria** - You may add multiple statements here with "And" or "Or" modifiers to build a more complex query. Used to narrow the criteria.

![NOTE](image)

You must use the "Refresh" button each time you add a filter line to submit the query to the database. Otherwise, just clicking **Add** will not refresh the data; it will just put the statement in the filter window. Remember, SyteLine 7 is stateless (disconnected). To return the result set to the parent form, click **OK**.
Applying a saved query

Navigating to the query form is the first step. Then you can select your saved filter from Actions + Filter + Apply Saved Filter

Setting up a filter prompt

To set up a filter that prompts you for the value, save a filter with a "?" in the field you want to be prompted for as shown below.

When you apply this saved query, the system will simply prompt you for the value.
SyteLine provide the user with default queries for some forms. The queries are found in the Actions menu. They can be modified, just as any saved query can be, by opening up the appropriate query from, opening the saved query by selecting "Open" in the Filter option in the Actions menu, making changes, and then saving the query.

<table>
<thead>
<tr>
<th>Form</th>
<th>Menu Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO Lines</td>
<td>Filter Due Next 7 Days</td>
</tr>
<tr>
<td>CO Blanket Line Releases</td>
<td>Filter Due Next 14 Days</td>
</tr>
<tr>
<td>PO Lines</td>
<td>Filter Due Next 30 Days</td>
</tr>
<tr>
<td>PO Blanket Line Releases</td>
<td>Filter Past Due</td>
</tr>
<tr>
<td>PO Requisition Lines</td>
<td></td>
</tr>
<tr>
<td>A/P Transaction Detail</td>
<td></td>
</tr>
<tr>
<td>A/R Transaction Detail</td>
<td></td>
</tr>
<tr>
<td>Estimate Lines</td>
<td>Filter Current and Future Estimates</td>
</tr>
<tr>
<td>Job Orders</td>
<td>Filter to Start Next 7 Days</td>
</tr>
<tr>
<td>Job Operations</td>
<td>Filter to Start Next 14 Days</td>
</tr>
<tr>
<td>Projects</td>
<td>Filter to Start Next 30 Days</td>
</tr>
<tr>
<td>Project Tasks</td>
<td>Filter Past Due</td>
</tr>
<tr>
<td>Estimate Jobs</td>
<td></td>
</tr>
<tr>
<td>Estimate Operations</td>
<td>Filter Current and Future Estimates</td>
</tr>
</tbody>
</table>
Using CURDATE( ) in Queries

CURDATE( ) stands for "current system date" and is a Filter option that can be used with query forms. It must be used in ALL CAPS. The argument inside the parentheses specifies the number of days before or after the current system date.

For example, a query with both of the CURDATE statements below would be filtering for orders with due dates inside the range starting on the current system date and ending seven days in the future.

- AND DueDate > CURDATE(-1)
- AND DueDate < CURDATE(8)
Practice: use query to filter

Review the listing of Shortcut Keys and Hotbar buttons in the preface. Identify those you could use to perform the tasks learned in this section.

1. Open the Item Stockroom Locations form. Set in refresh mode.
2. Select Ctrl + Q. (or Actions + Filter + By Query)
3. Build the query:
   
   **Primary Tab**
   
   a. Whse = Main/Item like BK*/Rank <3
   
   • How many objects were returned? ______
   
   • How many records did the BK-27000-0003 have? ______
   
   • Which records had an on hand quantity? ______

   **Additional Criteria**

   b. AND QTY ON HAND < 10
   
   • How many records are there now? ______

   4. Save the query. Give it any name you like.
   5. Click the Cancel button on the Query form.
   6. Use the saved query to filter the data on the Item Stockroom Locations form.
Printing the current record or collection

**Key Points**
You can print the data in your forms without a special report by using the following commands under the Form menu:

- **Print**
- **Print Preview**—Display a preview of the record or collection you want to print. Information from the current record or the current collection is printed in the columns
- **Print Setup**—Identify default settings for the current printer.

**Print Preview**

![Print Options dialog box](image)

**Form + Print Preview**
Print preview allows the user to print the current form's record or record set depending on the "type" you choose:

- **Collection Properties** - Prints the entire record set stored on the client. Default is 200 records. You may select all fields from the form or click the fields individually to either select or deselect that field from the printout.

- **Current Field Data** - Prints only the active record on the form. You will see the ">>" if you are looking at the grid.
**Practice: print out record**

1. Go to the Purchase Order Lines form.
2. Select **Print Preview** from the Forms menu.
3. Take a look at but do not print the Collection Properties. This would print too much info for this exercise.
4. Instead select **Current Field Data**. Choose the appropriate fields and print this page.
Viewing and printing simple graphs of data

**Key points**
When you have a form in refresh mode, you can create simple graphs of one value and one label by using Actions>Graph

**Procedure**

1. Open a form.
2. Put it in refresh mode.
3. Select Actions>Graph,
4. Select the value to be graphed.
5. Click Next
6. Select the label to appear on the graph.
7. Click Next (clicking Done would exit you out of the graph feature); you’ll see the graph.
8. Use the fields to change the display. When you’re finished, click Done.

**Type**
Select the type of graph to display, including bar graphs, line graphs, graphs with three-dimensional effects, and so on. If you do not know what type of graph you want, select different types from the list and evaluate them. Click the Refresh button to redraw the graph.

**Scroll By and Reset Scrolling button**
Specify the number of horizontal sections displayed at one time for the current graph. Each section displays information from one record. To change the display, enter a new number and click Reset Scrolling.

**Print Graph button**
Click to Print. If you use a color printer, the online colors are preserved in the print. If you use a black-and-white printer, the online colors become various shades of gray.

**Previous/Next button**
Use these buttons to move back and forth between the steps of creating the graph. For example, after viewing a graph of one value, you can click previous to change label or value, then click Next to create the graph.
Section 1: How to view data

**<<Previous & Next>> buttons**
Use these buttons to scroll back and forth on the current graph.

**Done button**
Close the graph feature.

**Example**
For example, suppose you wanted to see a graph of on-hand quantities by item. You would follow the steps below.

1. Navigate to Item Stockroom Locations.
2. Make sure form is in refresh mode.
3. Select **Actions>Graph**.
4. First select **On Hand (QtyOnHand)**.
5. Click **Next**.
6. For the Label, select **Item**.
7. Click **Next** to return the graph. (Do not click Done, which will return you to the application without showing the graph.)
8. Double-click the body of the graph and select **Options + Reset** to defaults.
Section 2: How to work with the data
Editing data in a collection

When you open a form and retrieve records, you’re actually copying data from the SyteLine database to your desktop. For example, you may copy item records, or bill of material records, or customer orders. The data copied is called a "collection."

When you edit the collection by updating, adding, or marking records for deletion, you are only editing the data in the collection on your desktop, not the SyteLine database. Only when you save the collection does the system update the SyteLine database with all your changes.

Because the collection is a copy of the data, you can edit, add, or mark multiple records for deletion--you do not have to save after every change you make. While you’re editing the collection, the system keeps track of all the changes and marks each record with the types of changes made using the indicators shown below. The indicators show up in the row labels seen in the grid mode.

<table>
<thead>
<tr>
<th>Row Label Indicator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>■</td>
<td>The record is already saved in the database and is the current (selected) record in the collection. In a multiview form, this is the record that displays in the detail view.</td>
</tr>
<tr>
<td>(n)</td>
<td>The record is new and contains no validation errors. It has not yet been saved.</td>
</tr>
<tr>
<td>(m)</td>
<td>The record has been modified and contains no validation errors. It has not yet been saved. A modification is considered to occur whenever there is a change to a value in any field.</td>
</tr>
<tr>
<td>(d)</td>
<td>The record has been marked for deletion. The record will be removed from the database when you save the record or the collection containing it.</td>
</tr>
<tr>
<td>(e)</td>
<td>The record is new, has been modified, or has been marked for deletion, and contains at least one validation error. The letter e is added to the row label when you navigate away from the record, receive a validation error message concerning the record, and do not correct the error. When you subsequently try to save the record, or the entire collection containing the record, the system repeats the validation error message, and you cannot save it until the error has been corrected.</td>
</tr>
<tr>
<td>*</td>
<td>This indicates the empty row that always displays after the last record in a collection. You can click this row to insert a new record.</td>
</tr>
</tbody>
</table>

Below is an example of row label indicators.
Adding records

When in the Refresh mode (and only in the Refresh mode), you can add a new record in either form or grid view by clicking the New button or selecting the New option in the Actions menu or pressing CTRL+N. The color of the field tells you whether it's required, optional, or real-only.

<table>
<thead>
<tr>
<th>Color</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yellow</td>
<td>Required</td>
</tr>
<tr>
<td>Green</td>
<td>Required, but if you leave it blank the system will generate it for you</td>
</tr>
<tr>
<td>White</td>
<td>Optional</td>
</tr>
<tr>
<td>Gray</td>
<td>Read Only</td>
</tr>
</tbody>
</table>

In green fields, you can use the question mark (?) to tell the system to generate the value using a prefix you supply.

For example, the customer ID field on new customer records is green, meaning it's required but that the system will generate it for you if you don't supply the value. If you enter "JB?" in that field, the system will expand the ID to use all the characters in the field and increment the number. The first time you enter this and save, the system will generate JB00001 as the customer ID. The next time you enter "JB?", the system will increment and generate JB00002 as the customer ID.
Finding and adding values in a drop-down list field

Key points
Some drop-down list fields have hundreds of possible values. We do not recommend you scroll through the possibilities. Instead use one of the following options to find or add the value you desire:

- Find menu option
- Drop-down list filter
- Add menu option

The system uses two basic drop-down list types: business-data lists and option lists. The Find and Add menu options are ONLY available on business-data drop-down lists.

Business-data lists are generated from records you maintain in another form. For example, you will maintain all your items records in the Items form. When you add an item record to that form, it will appear as a drop-down list option in the item fields on other forms.

Option lists are built-in to the system, rather than being created and stored in the database. You cannot usually change the options in these lists, and they usually provide only a few options.

Using the Find menu option

Edit>Find or CTRL+F or Right-click+Find or select Find toolbar button

When you select Find, the system will bring up the query form for the form supporting the field.

1. Enter query criteria.
2. Click the Refresh button to see the values it will return.
3. Highlight the value you want to return to the field.
4. Click the OK button to return the value to the drop-down.
Filtering a drop-down list

There are two ways to filter on a drop down field:

- Use the first few characters to narrow down the possible values, then click the drop-down arrow.
- Enter filter criteria using the wild card character, then click the drop-down arrow.

For example if you enter "f" in a drop-down field for Item ID and click the drop-down arrow, the system will display the item records starting with those that begin with "f".

On the other hand, if you enter "*f*" and click the drop-down arrow, the system will return all items with an "f" somewhere in the ID.

**Comparison operators (<,>,=,<>) are not supported when filtering a drop-down list.**

Using the Add menu option

If a value does not exist in a drop-down list, and you need it, you can add the new value and insert it into the field.

1. Open a form and display the record you want to add the field value to.
2. Click in the drop-down list field you want to add an option to.
3. Select the Add feature by:
   - Right-clicking in the field and then, from the context menu, select Add
   - Selecting Add Value for Current Field from the Edit menu
   - Clicking the Add Value button on the toolbar
4. Complete the fields for the new record.
5. Save your changes and close the form.
6. The system will return to the original form and insert the new value into the field.
Copying records

Copying a record, rather than creating a new one, and then modifying it, can often save time in repetitive data-entry tasks.

To copy a record:
1. Select the record to copy.
2. From the Actions menu, select Copy.
3. A copy of the selected record is inserted as the next record.
4. Edit the record as needed.
   a. If the record contains a field with a number that is automatically assigned and cannot be manually changed, the system assigns the next available number to the copied record when you save it.
   b. If the record contains a field with a number that is automatically assigned but which can be changed manually, the number is duplicated in the copied record. You can update the value manually before you save the record. To allow the system to assign the next available number automatically, make the field blank before you save the record.
5. Once you made all the necessary changes, save the record.
Checking for errors

Key points
Most forms validate new and modified records and report validation errors. The system displays messages about any field that contains an invalid value or about any field that requires a value but does not contain one.

The validation procedure occurs, and any error messages display, when you:
• Navigate away from a new or modified record.
• Attempt to save new or modified records.
• Select Validate from the Actions menu.

Some fields are set to validate immediately and not wait until you perform one of these actions. In these cases, validation occurs as soon as you attempt to move the focus to another field in the same record.

Correcting Errors
When you perform an action—other than an action to save all records—that triggers validation, the system displays an error message for the FIRST field in the CURRENT record that contains an error. If there are multiple errors, the system then cycles through each field with an error.

If you attempt to save a form that has multiple records with errors, the system reports which records in the current collection contain errors. You cannot save the collection updates until ALL errors have been corrected.

To correct the current record
1. When the system presents the error message and prompts you to respond, click Yes.
2. The insertion point moves automatically to the field containing the error.
3. Enter a valid value.
4. From the Actions menu, select Validate.
5. If the system displays an error message, repeat steps 1 and 2 until no field in the record contains an invalid value.

To correct all records in the collection
1. Note the record numbers in the error message. They correspond to row labels in the grid form.
2. Navigate to a record indicated by a row number.
3. From the Actions menu, select Validate.
4. Note the name of the field reported in the error message.
5. Move the insertion point to the field named in the error message.
6. Enter a valid value.
7. Repeat steps 3 through 6 until all fields in the current record are valid.
8. Repeat the entire procedure until you have corrected all records indicated in the error message from the save operation.
Deleting records

You can delete a single record or a group of adjacent records from a collection.

The system does not actually delete a record from the database until you save your changes.

If you still see the (d) row label indicator next to the record, that means the deletion has not been saved to the database.

If you change your mind about deleting a record, you can unmark those records using one of the methods for undoing changes.

Deleting a single record

1. Select the record you want to delete.
2. From the Actions menu, select Delete, click the Delete button on the toolbar, or press CTRL+D.
3. When the system notifies you that the record will be permanently deleted after a Save action, click OK.
4. To delete the records permanently from the database, save the collection.

Deleting a range of records

1. Click the row label for the first record in the group you want to delete.
2. Hold down SHIFT and click the row label of the last record you want to delete.
3. From the Actions menu, select Delete, click the Delete button on the toolbar, or press CTRL+D.
4. When the system notifies you that the records will be permanently deleted after a save action, click OK.
5. To delete the records permanently from the database, save the collection.
Undoing changes

You have four options if you want to undo any changes you've made. "Refresh" in the options below refers to refreshing your collection by updating the record in your collection with the current values in the database.

- Remove a new record: select Delete from the Actions menu, click the Delete toolbar button, or highlight the record and press CTRL+d.
- Refresh current record: select Refresh Current from the Actions menu, click the Refresh Current toolbar button, or press CTRL+F5. This will undo changes only to the ONE record you've selected.
- Refresh all records: select Refresh from the Actions menu, click the Refresh toolbar button, or press F5. This will undo the changes you've made to ALL of the records in the collection and reapply any original filter criteria you used on the form before making the changes.
- Cancel changes and close form: select Close and Cancel Changes from the From menu. This will discard any changes you made and close the form.

Once you save records that had been changed or marked for deletion, you cannot undo the changes.

If you still see the row label indicators of (m), (e), (n), or (d), this means you haven’t saved your changes and can undo them.

If the form contains a subcollection (displayed as a grid in the detail view), the system will refresh either the subgrid only or the whole record, depending on where you have placed focus.

To refresh the subcollection, make sure you have placed your cursor in a field of the subcollection.

Place the cursor in a field of the main record to refresh the main record(s).

For example, if your cursor is in the sub-grid displayed in the detail view and you select to refresh, the system will only refresh the records in the sub-grid. It will not refresh the other fields of the main record.
Saving records

When saving records, you have two options: You can save a single record, ignoring changes to other records in the collection, or you can save all records at one time.

Saving a single record in your collection
1. Select a record.
2. From the Actions menu, select Save Current.

Saving all records in your collection
Do one of the following:
• From the Actions menu, select Save.
• On the tool bar, click the Save Form button.
• Press CTRL+S.
Practice: data entry

1. Open one of the forms below
   • Items
   • Purchase Orders
   • Customer Orders
   • Job Orders
2. Put form in refresh mode
3. Add a record in the form view, but do not save it yet. Try adding a value in a drop-down field by right-clicking on the field and selecting Add or Find.
4. Put form in grid view
5. Add a second record in grid view
6. Save the records
Finding and replacing values in a range of records

Key points
If you want to update a number of records with the same value, you can copy and paste, but you can do it more quickly with the Replace Value in Collection feature.

Replace

Edit \ Replace Value In Collection
To update a range of cells with the same value:
1. Place the cursor in a cell in the column you want to update. The current row and all subsequent rows will be included in the process.
2. Select Edit \ Replace Value In Collection
3. Use this dialog box to replace values in a field with a new value that you specify.

TIPS:
• The search works beginning with the selected record and going on from there. It does not loop back through the beginning of the records. This means that, if you want to search only the last part of a collection, you can start with the focus on the first record from which you actually want to search.
• When you use this dialog box, and click OK, the system prompts you and queries whether you want to change an individual value found, or all values that match the criteria. This allows you to selectively replace values only in certain records (by selecting Yes or No) or in all records at once (by selecting Yes to All).

Replace
The value that you want to find and replace.

When entering values on which you want to search, you can use a partial value. For example, to find any value that contains the string "test", you would enter test and clear the Case Sensitive check box. This would locate values such as Test case, Amy’s testing results, Sales Contest. This is known as using an "implied wildcard."

NOTE: The Find Value and Replace Value features do not support use of the wildcard character, the Null keyword, or comparison operators. These characters in such searches are treated as literal values.
Section 2: How to work with the data

**All Values**
Select this checkbox to replace information in a field regardless of the field's current value. Clear this checkbox to replace information in a field only if it contains the value contained in the Replace field.

**With**
The new value to replace the value entered in the Replace box.

**In Collection**
The collection you want to search. This should default to the collection you are currently working with.

If you have questions, return to the form and click a section of the form that displays the collection you want. On the Help menu, click About This Form. The name of the current collection appears in a dialog box.

**In Property**
The name of the field whose values you are replacing. The default value for this field is whatever field the cursor was in when you opened this dialog box. So, to have the field in which you want to replace values preselected here, make sure that field is selected when you open this dialog box.

**Case Sensitive**
Select this check box to search for the exact case (capital and lower case letters) you typed in the Replace box. Clear this check box to match values even if they differ in case with the value specified in the Replace box.

---

**NOTE**
If you’re performing a find/replace on a checkbox field, remember that "0" = deselected and "1" = selected. For example, if you wanted to replace items records that had their Backflush checkbox selected, you would enter "1" in the Replace field.

If you’re performing a find/replace on a checkbox field, remember that "0" = deselected and "1" = selected.
Practice: update a field on a range of records

You'll be changing the due date of a number of order lines for Ting Tang Bicycles.

1. Open the Customer Order Lines form.
2. Filter for order lines from Ting Tang Bicycles that have a status of "Ordered"
3. Put the form in grid mode (you don’t have to do this, but you’ll see the changes better in the exercise)
4. Place your cursor in the status field.
5. Select Edit>Replace Value in Collection.
6. Notice the value in the In Property field.
7. Close the Replace Value in Collection form. Put your cursor in the date field, and select Edit>Replace Value in Collection again.
8. Notice the value in the In Property field. It should be for the date this time.
9. Select the All Values checkbox.
10. Enter a date two weeks from today into the With field
11. Click OK.
12. When the process finishes, save your records or refresh them from the database.
Notes Overview

Key points
You can annotate a record or a collection of records by attaching one or more notes.

- Each record can have multiple notes.
- Each note has two parts: a description and a body. The body can be text OR an attachment. For example, a note for a bill of material might include text instructions for packaging or the engineering drawing.
- You can make some notes specific to a particular record; other notes you can use over and over on multiple records.
- A number of standard SyteLine reports print notes.

The table below summarizes the types of notes available and how to create them.

<table>
<thead>
<tr>
<th>Note type</th>
<th>Description</th>
<th>How to Create</th>
</tr>
</thead>
<tbody>
<tr>
<td>Class</td>
<td>Attached to all records in a collection</td>
<td>Actions + Notes for All</td>
</tr>
<tr>
<td>Current</td>
<td>Attached to ONE record in a collection</td>
<td>Actions + Notes for Current</td>
</tr>
<tr>
<td>Reusable: System</td>
<td>Can be used as a class or current note by ANYONE</td>
<td>View + System Notes</td>
</tr>
<tr>
<td>Reusable: User</td>
<td>Can be used as a class or current note only by the USER THAT CREATED THE NOTE</td>
<td>View + System Notes</td>
</tr>
</tbody>
</table>

Note types
There are two note types. You can attach multiple notes, of either type, to a record. Once you attach a note of any type to a record, all other users of the system can read the note.

Current notes (also called object notes)
Notes for a single record. These notes are attached to the currently selected record. With these notes, you can:

- Use reusable and non-reusable notes
- Flag the note as internal or external
- Print the note on reports (not all current notes are tied to reports)

Class Notes
Notes for all records in a collection. These notes are attached to every record in a collection. For example, if you attach a class note to one customer record, it is automatically attached to all customer records in the database, not just the part of the collection you have displayed in your form. With these notes, you can:

- Only use reusable notes
- Flag the note as internal or external

Class notes do NOT Do not print on any standard SyteLine reports. You can view these types of notes only through the form for the collection to which the notes are attached.
Reusable Notes
Reusable notes can be used as class or current notes multiple times. There are two kinds of reusable notes:

User notes
Once created, a user note can be reused and attached to records only by the person who created the note. For example, if Sally creates a user note in the System/User Notes form, she can later view that note and attach it to other records. However, when Pete opens the System/User Notes form, he cannot see Sally's notes or attach them to his records.

User notes do NOT print on standard SyteLine reports.

System notes
Once created, a system note is available for use by anyone else on the system. For example, if Joe creates a system note, both he and Jane can later view that note in the System/User Notes form. They can also both attach it to as many records as they want.

System notes CAN be printed on reports.

Internal/External Notes
All notes can also be classified as either internal or external notes. If you select the Internal check box for a note, the system tags it as an internal note. Otherwise, the system treats the note as an external note. This classification is used when selecting which notes to print on reports.

Printing Notes on Reports
Many reports and utilities allow you to specify what kinds of notes can be printed as part of the output. Sometimes the Print External Notes and Print Internal Notes options are used in conjunction with other note-printing options.

On forms where Print External Notes and Print Internal Notes are the only 'print notes' options, it depends on the form itself as to which notes the system prints.

For more information on which notes are printed on standard SyteLine reports, see the online help topic "Printable Notes".
Creating notes for the current record

**Actions + Notes For Current**

**New**  
Adds a new note for this record only.

**Delete**  
Deletes selected note.

**Attach Detach Reusable**  
Attach a reusable note to the current record.

**Attach File or Open Attachment**  
Attach or open a file created in an external application.

**Internal**  
Select the check box to mark the note for internal use only. The note can subsequently be excluded from report printing based on whether it’s internal or external.

**NOTE**  
Attachments must be in a shared folder on the network for other users to view it.
Creating reusable notes

View + System Notes
Use system notes to retrieve common messages that you plan to use over and over. For example, “always store this item right side up,” or “check all bolts for proper torque prior to packaging.” You may enter these notes once and reuse them as often as you like without re-entering the note time and again.

System Notes vs. User Notes
System notes are reusable notes that can be read and attached by any user on the system. User notes are reusable notes that only the author can read or attach.

Attach File
Use the Attach File option to attach a file or picture to this record. This is optimal for drawings or documents stored across the network.

System notes should be organized for ease of use when the file gets to be large. An example would be to use prefixes that match the class in which they will be associated like CO, PO, Item, Transfers, Job, BOM, etc.
Practise: create notes

1. Add a system note.
   - Create your own subject and text
   - Don't forget to mark it as "system"

2. Apply system note to record
   - Open the Items form and find FA-10000
   - Select Actions>Notes for Current (or click the Notes button)
   - Select "Attach Reusable"
   - Select your system note and click OK

3. Capture picture
   - Make a trip to the Internet and find a picture of any bike
   - Right-click and save the picture in a location you can find easily (c:\temp)

4. Use picture as note
   - Open Notes For Current for FA-10000
   - Add note
   - Type "FA-10000 Drawing" for the subject
   - Click in the notes dialog box and select Attach File
   - Find your picture and insert it into the notes
   - Click OK

5. Open notes for FA-10000, then open picture attachment
Printing reports

**Key points**

Printing reports is a two-step process:

1. Define what you want to print on the report
2. Click Preview or Print button

You can send the report to the printer or save it in a number of file formats on your computer.

**Sample form**

![Sample form](image)

Reports usually have three parts:

1. **Checkbox and dropdown parameters**
   Use these fields to select the type of information you want to print.

2. **Range filters**
   Use these fields to select ranges of records to print.

3. **Action buttons**
   - Preview: display report on the computer
   - Print: send to printer or save as file
How to define whether you print or save the report

We’ve included this topic so you know you have options; your system administrator will set up these options for you. The system looks for report options in these places in the order shown below.

1. Report Options: format by user, report, or device
2. Intranets: default for all reports

\Master Explorer \ System \ Report Options

Use this form to set the default report options. The options you assign apply to a particular user, a particular report, or a particular device. Once set, these options remain as defaults until you change them on this form. For more information on setting up report formats, see the system administration guides. Available report output formats include:

- Acrobat Format (PDF)
- Comma Separated Values (CSV)
- Crystal Report (RPT)
- Excel 8.0 (format used with Excel 97 and Excel 2000)
- Excel 8.0 extended - (format used with Excel XP and Excel 2003)
- HTML 4.0
- Printer
- Rich Text Format
- Word for Windows
- XML
- Text
Practice: print a report

1. Go to the module you’ll be spending most of your time to do your job.
2. Open any report
3. Select a range to print
4. Click Preview
5. Close the preview
6. Click Print
Running activities and utilities

Key points
Activities and utilities are used to update the main records in a module. The difference between them is that activities are processes users usually run more often. Utilities are run less often.

You’ll find process parameters on a majority of the Activity and Utility forms. After you select the parameters, you will process Activity or Utility in one of two ways:

- Process with Preview and Commit
- Process only

Samples

Process with Preview and Commit

Activities and Utilities with the preview option allow you to perform a trial run. Nothing is updated in the database, but you see in the grid at the bottom what would happen. If the results look correct in the Preview, select the Commit radio button and click the Process button. When you commit, you update the database.

In some processes the Preview is not optional. Often these processes print a report that you must view first. When you preview, then the commit radio button will activate.
Process only

Activities and Utilities do not allow you to perform a trial run. With these forms you simply select the desired parameters then run the process against the database.

How to verify the process was successful

Processes executed immediately

Many activities and utilities are immediately processed. You will receive a feedback message from the system saying the process completed. For example, you'll get the message shown below when you run the Material Planner Workbench activity successfully.

Processes placed in background task queue

However, some processes are not performed immediately. These are placed into the background task queue. You'll know this is the case when the system gives you a feedback message saying the "task was submitted" as shown below.

When you receive this message you'll have to open the Background Task History form to verify the process completed successfully. The form is shown below.
Section 2: How to work with the data

\Master Explorer \ System \ Background Task History

Submitted
When you clicked the Process button you submitted to process.

Started
When the system begins executing the process you submitted.

Completed
When the system finished the process. Regardless of what you read in the Task Messages area, a process is not complete until you have a value in this field.

Return Status
When the process completes, the system will fill in the return status of the task:

• Task Succeeded
• Task Failed - Error, followed by the return code
Practice: run an activity

1. Go to the module you’ll be spending most of your time to do your job.
2. Open any activity
3. Select activity parameters
4. If the Preview option is available, use it.
5. Process the activity
6. Note the type of feedback message. If it says the "task was submitted," go to the Background Task History form to verify it completed successfully.
Exporting a file

Key Points
You can move data into a number of file types that can be read by other programs.

Form & fields

Form + Export to File
Use this dialog box to export the current collection to an external file that can be imported into other programs, such as a spreadsheet. The external file can be either comma-separated or tab-separated. Each record in the collection becomes a row in the exported file. Each field (property) becomes a column in the exported file.

Source Collection
This is the name of the collection to be exported. To identify the name, return to the form and click the grid displaying the collection you want. The name of the second menu is the name of the current collection.

Cap Option
Choices are:
- From data currently in the collection - Export the records retrieved in the current collection.
- Unlimited query - Export all records in the collection from the application database. SyteLine applies the current filter criteria and sort order to the collection, then exports records from the collection in the application database.

Output File Type
Choices are comma separated (.csv) or tab separated.
Moving data to and from Excel

**Key points**
You can easily move data back and forth to and from Excel without exporting the data as a file.

**Copying an entire collection**
There are two ways to copy a collection in a form to a spreadsheet:

- Use the To Excel menu option
- Highlight and copy all the records in your collection

These procedures can copy only the records that have actually been retrieved from the database.

**Using the To Excel menu option**
Use the Actions>To Excel menu option (or the To Excel toolbar button) to save a collection to a file and then automatically open the file in Microsoft Excel. The records are placed in the file [Form name]+[Export sequence].csv in the local My Documents folder. For example, My Documents\itemsExport4.csv.

If Excel is installed on your local system, it is launched and the new file is opened as a spreadsheet. If you have a different application set up to open comma-separated value (.csv) files, that application will open the file instead.

If the currently selected field is either in a grid or has a related grid on the form, you see this prompt: “Do you want to match the sequence of columns in the related grid?” Click Yes if the spreadsheet columns should match the order of the grid on the form. Click No if the spreadsheet columns should match the order of the property list in the form's IDO.

Only data displayed in the current collection is populated into the spreadsheet, and the usual export-to-file rules apply.

Some collections may not have the To Excel option enabled.

**Using the highlight method**
The following procedure assumes that you have the form open and the collection you want to copy showing in the grid view.

1. Click the blank box in the upper-left corner of the grid. This action selects and highlights the entire collection.
2. Press CTRL+C or select Edit > Copy. The contents of the collection are copied to the system clipboard.
3. In your spreadsheet program, select the cell you want to be the first (most upper-left) cell of the collection. Typically, this is the first cell in the worksheet.
4. Press CTRL+V or use whatever command your spreadsheet program uses to paste in the material.

The system does not copy and paste the header row of the collection as part of this procedure. If you want to copy the header row as well as the records, you must use the To Excel menu option.
Copying selected records
You can copy a single or multiple records from a collection to a spreadsheet.

The following procedure assumes that you have the form open and showing the collection you want to copy from.

**Copying a single record**
1. Click in the left-most column for the record you want to copy. This action selects and highlights the entire record.
2. Press CTRL+C, or select Edit > Copy. This action copies the record to the system clipboard.
3. In your spreadsheet program, select the cell you want to be the first (left-most) cell of the pasted record.
4. Press CTRL+V or use whatever command your spreadsheet program uses to paste in the material.

**Copying multiple records**
1. Click in the left-most column for the first record you want to copy.
2. Shift-click in left-most column for the last record you want to copy. These actions select and highlight the subset of records.
3. Press CTRL+C, or select Edit > Copy. This action copies the selected records to the system clipboard.
4. In your spreadsheet program, select the cell you want to be the first (most upper-left) cell of the pasted records.
5. Press CTRL+V or use whatever command your spreadsheet program uses to paste in the material.

You can also select non-adjacent rows for the subset. To do this, use CTRL-click to select multiple non-adjacent rows, and then paste them into the spreadsheet as you would any other contiguous set of records.

Copying selected columns
You can copy a single or multiple columns from a collection to a spreadsheet.

The following procedure assumes that you have the form open and showing the collection you want to copy from.

**Copying a single column**
1. Click in the header row for the column you want to copy. This action selects and highlights the entire column.
2. Press CTRL+C, or select Edit > Copy. This action copies the contents of the column to the system clipboard.
3. In your spreadsheet program, select the cell you want to be the top (upper-most) cell of the pasted column.
4. Press CTRL+V or use whatever command your spreadsheet program uses to paste in the material.
Section 2: How to work with the data

Copying multiple columns
1. Click in the header row for the first column you want to copy.
2. Shift-click in header row for the last column you want to copy. These actions select and highlight the subset of columns.

You cannot select non-adjacent columns for the subset. That is, you can use CTRL-click to select multiple non-adjacent columns, but when you paste them into the spreadsheet only the first column (or first set of adjacent columns) actually gets pasted into the spreadsheet.

If you have one or more columns that are not adjacent to other columns you want to copy, you can rearrange the grid so the non-adjacent columns to a position adjacent to the other columns you want to copy. Then select the set of columns to be copied, once they are all in a contiguous set.

3. Press CTRL+C, or select Edit > Copy. This action copies the selected columns to the system clipboard.
4. In your spreadsheet program, select the cell you want to be the first (upper-most) cell for the pasted columns.
5. Press CTRL+V or use whatever command your spreadsheet program uses to paste in the material.

Copying selected cells
You can copy a single cell or a block of cells from a collection to a spreadsheet.

The following procedure assumes that you have the form open and showing the collection you want to copy from.

Row labels are pasted in the spreadsheet as the first column. The labels are for reference only and should not be copied and pasted back into a grid. In the spreadsheet, you can delete the row-label column, unless you want to keep it for reference purposes.

Copying a single cell
1. Click in the cell you want to copy.
2. Press CTRL+C, or select Edit > Copy. This action copies the contents of the cell to the system clipboard.
3. In your spreadsheet program, select the cell where you want to copy the contents.
4. Press CTRL+V or use whatever command your spreadsheet program uses to paste in the material.

Copying a block of cells
1. Click in the first (upper-left) cell you want to copy.
2. Shift-click in last (lower-right) cell you want to copy. These actions select and highlight the block of cells.

You cannot select non-adjacent cells. That is, you can use CTRL-click to select multiple non-adjacent cells, but when you paste them into the spreadsheet only the first cell (or first contiguous block of cells) actually gets pasted into the spreadsheet.

3. Press CTRL+Insert. This action copies the selected block of cells to the system clipboard.
4. In your spreadsheet program, select the cell you want to be the first (most upper-left) cell for the pasted columns.

5. Press CTRL+V or use whatever command your spreadsheet program uses to paste in the material.

**Notes on copying**

Carriage returns and line feeds in a multi-line cell are removed when you copy a row to the clipboard. So, if you have multi-line cells, you must copy those cells separately or reconstruct them in the spreadsheet.

Numeric values represented by check boxes in grids are 0 (zero) when cleared and 1 (one) when selected. These values are transferred to and displayed in spreadsheets as 0 and 1, respectively. So, if you plan to paste content from a spreadsheet into a grid and a check box value is included, you must enter the correct values as 0s and 1s in your spreadsheet.
**Pasting from a spreadsheet into a collection grid**

**Pasting selected records (rows)**

You can paste the contents of selected records that you have worked on in a spreadsheet into a grid.

This might be useful, for instance, when you have copied a set of records from the system into a spreadsheet for editing and now you want to return the contents of the records, with the changes, to the system.

To paste selected rows into a grid:

1. Open the form into which you want to paste the records.

   To paste the records into a blank grid, you can do a Filter-in-Place query that you know will retrieve no records. This puts the form in "new" mode. For more information, see Finding Records with Filter-in-Place.

2. In the spreadsheet, select the desired rows and then press CTRL+C to copy them to the system clipboard.

   Make sure that you do not include the header row, if you have one. If you do, the paste operation probably will not complete successfully.

3. In the grid, click inside the field at the location where you want to copy the data. In many cases, especially if you have a blank form in "new" mode, this is the first cell in the grid, though you can paste them in anywhere.

   Do not create a new row; the paste action will automatically create the row.

   Do not click the row label. Instead, click inside any field on the row you want to replace or below which you want to append the new rows. If you are replacing multiple rows, the paste action will replace the row in which you clicked and each subsequent row, replacing the contents of those rows except for the read-only fields.

4. From the Edit menu, select one of the following options:
   a. To insert new records at (below) the selected field, select Paste Rows Append.
   b. To overwrite the content of existing records, beginning with the selected field, select Paste Rows Overwrite.

   This option only overwrites active fields. Fields that are read-only are left unchanged.

   Do not attempt to use CTRL+V to paste the rows. Doing so causes the system to write the entire contents of the source row to a single cell. Use one of the options listed in step 4 above.
The spreadsheet and the grid must have the EXACT same visible column sequence. The first column in the spreadsheet must correspond to the first column in the grid; the second column in the spreadsheet must correspond to the second column in the grid; and so forth.

Normally, if you originally copied from a grid into the spreadsheet, the data schemes are identical. However, in some cases, this is not true because the order of the grid may not match the order of the collection that was exported; in those cases, you must reorder the columns in the spreadsheet to match the grid order.

Be careful, too, when ordering columns in the grid view. Because the paste order matches that of the spreadsheet, if you paste a value into a column that affects the value of a later column, then when the later column value is pasted, it might overwrite the desired (calculated) value with the value from the spreadsheet.

The maximum number of rows you can paste into a form at one time depends on the memory resources of your computer. Pasted rows are held in memory until you save them. You can avoid out-of-memory conditions and related errors by dividing a large number of records into smaller batches and then pasting and saving each batch separately.

**Errors**
SyteLine will validate your data when you paste it. Data mismatches will generate data error messages.

If you edit a cell in response to a validation message during the paste operation, the paste operation ends with the current record. Therefore, we recommend that you respond "No" to all prompts for validation during the paste operation, and then go back after the operation is complete to edit these fields.
Pasting the contents of a single cell
You can paste the contents of a selected cell in a spreadsheet into a grid.

This does not work for blocks of cells. If you attempt to copy and paste blocks of cells, the system attempts to write the contents of all source cells to a single cell in the destination grid.

To paste the contents of a single cell from a spreadsheet into a grid cell
1. Open the form into which you want to paste the content.
2. In the spreadsheet, select the cell you want and then press CTRL+C to copy the content to the system clipboard.
3. In the grid, click inside the field to which you want to copy the data.
4. Press CTRL+V, or select Edit > Paste. Note that this action overwrites any content previously in the field.

The type of contents in the source cell must match the expected type for the contents of the grid cell.

For example, if the grid is expecting an alphanumeric character string, the cell in the spreadsheet must contain alphanumeric character content. If the grid cell expects a numeral input, the source cell must contain only numeric content. If the field is a drop-down list, the data being copied must be a valid option.
Practice: export to and from Excel

In this exercise, you'll copy to Excel, then paste overwrite and paste append changes you made in Excel back into SyteLine.

1. Copy to Excel
   a. Open Excel.
   b. Go back to SyteLine and open the Purchase Order Lines form; filter for vendor 1.
   c. Put form into grid mode.
   d. Copy the column headings to Excel.
   e. Copy the rows to Excel.

2. Paste Overwrite from Excel
   a. In Excel, find a planned order line. Change the quantity of the line.
   b. Copy the line.
   c. Go back to the Purchase Order Lines form.
   d. Place your cursor in the row that matches the one you copied.
   e. Select Edit>Paste Overwrite.

3. Paste Append from Excel
   a. In Excel, add another line by copying a planned order line and pasting it after the last row.
   b. Copy the line.
   c. Go back to the Purchase Order Lines form.
   d. Place your cursor in any row.
   e. Select Edit>Paste Append.
Section 3: How to set up basic personalizations
Section 3: How to set up basic personalizations

How to create a personal menu

Key points
Instead of having to search through the master explorer, you can create a menu structure that includes only the forms you use.

Procedure

How to copy folders from the Master Explorer into My Folders
1. Use the Master Explorer to find the desired folder or form.
2. Right-click the folder or form in either the left or right pane.
3. Drag and drop into the My Folder area.

How to create a new folder
1. Highlight My Folders
2. Right click and select New Folder as shown below

3. Give your folder a name. You can change the name by right clicking and selecting Edit>Properties
4. Drag and drop other folders and forms into your folder.

If you want to delete a folder or form from My Folders, simply highlight the folder and select Edit>Delete or click the DEL key.
Practice: create a personal menu

In this exercise you’ll drag and drop forms you’d normally use in your job.

1. Use the Master Explorer to find the forms you normally use on the job.
2. Right-click, then drag and drop a folder.
3. Right-click, then drag and drop a specific form.
4. Create a new folder in My Folders and give it your initials.
5. Drag and drop all the forms and folders you copied in steps 2 and 3 into the new folder.
How to set up SyteLine to open forms when you login

Key points
Many users want to login to SyteLine and immediately have the system open the forms they use most often. You can do this easily using these features in My Folders:

- **Auto Run** - When you log on, forms listed in the AutoRun folder are displayed as opened, cascaded windows.
- **Pre-Load** - When you log on, forms listed in the PreLoad folder are automatically retrieved from the database into memory so they display more quickly when you open them later.

Procedure
Drag and drop the folders you want to autorun or preload into the correct folder in My Folders. In the example below, Items and Item Stockroom Locations will autorun when the user logs in.
Practice: set forms to automatically open

In this exercise you’ll set three forms to open automatically when you log into SyteLine.

1. Go to the module you use most on the job.
2. Identify three forms you’re likely to use the most.
3. Drag and drop them into the autorun folder.
4. Exit SyteLine.
5. Log back into SyteLine. The forms should have opened automatically.
How to set up SyteLine to open sets of forms with custom size and positioning

**Key points**

Sometimes you don't want SyteLine to simply open forms, but you want it to also present them in a specific layout. For example, someone who regularly works with job and planning forms might have two sets of forms they commonly use. They could save their favorite layout of both sets of forms and retrieve them when they need to work with them using the Form>Workspace feature.

![NOTE]

You cannot save a filter with a workspace. The system will bring up the forms in their sizes and positions in the default mode.

**Procedure**

**How to create a workspace**

1. Open the forms you're interested in.
2. Change size and position to fit your desires.
3. Select Form>Workspace.
4. Click New.
5. Give Workspace a name as shown below.

![Screenshot of Workspaces window]

6. Click Set from current forms. Notice the message will be updated to say it now includes the number of forms you have open as shown below.
7. Click Done.

**How to open a workspace**
Once you have defined your workspaces, follow these steps to open them.
1. Select Form>Workspaces.
2. Highlight the desired workspace.
3. Click Exit and Open.
Practice: create a workspace

1. Choose two forms you’d work with on a regular basis.
2. Open each.
3. Position and size them so you can see both.
4. Follow the procedure to create a new workspace for them.
5. Select Window>Close All.
6. Follow the procedure to open your workspace.
How to set cap size on records retrieved

**Key points**
By default SyteLine will retrieve no more than 200 records into a form at any time. You can change this default if you desire.

![Warning icon] This data cap applies to all forms.

### Settings

#### View \ Settings

**Use Default**
Retrieve the default number of records or list items. The default is 200.

**Retrieve All**
Retrieve all the records or list items in the database.

**Use Specified Max**
Specify the maximum number of records to retrieve. The value -1 appears in the box if the Use Default option is selected.
How To Setup Up Tabs

Tabbed View of Parent & Child Forms

Example

Tabs are another way to present linked forms. When you turn on the tabbed view setting each form you open becomes a parent form and a top level tab. Any form you open using buttons from the parent form becomes a linked form and child tab.

You can specify where the parent and child appear-top, side, or bottom-using the view settings.

Tabs can be reordered by clicking a tab and drag it around. Also, tab background color can be altered by right-clicking and select one of listed colors (please note that we currently do NOT persist this color selection)
Turning on Tabbed View

Main Menu \ View \ Settings

Turning Tabs On

1. Close all forms before setting your tab options.
2. Select the Tabbed Form Layout checkbox and then the desired Top/Parent Tab, Child Tab, and Tooltip options. You do not need to save, just close the settings form and the selections will take effect.

Image Tooltip

By selecting the "Use Image Tooltip" option, users can hover over a tab and see a form preview. This only shows the form, it does NOT reflect the most up-to-date data.

A new setting called Tabbed Form Layout lets you display tabs for each open form across the top of the screen. If you open a linked or modal child form from within another form, tabs for the child forms appear on the right side of the screen. You can click and drag to reorder the tabs across the top of the screen. You can right-click on a tab to change its color, to organize similar tasks by color. Tabs, tab order, and tab colors are not saved when you sign out.

A new setting called Display Explorer Buttons displays buttons in the Explorer. These buttons are visible only when the Explorer is displayed, and they allow you another way to navigate within the Explorer.

A new setting called Remember the navigation path makes the system remember your Explorer settings.
How to change the mode the form opens in

**Key points**

There are three initial command settings:

- Refresh
- FilterInPlace
- New

You can change these for a user, group, or all users.

**Procedure**

1. Enter Edit Mode.
2. Select *Edit>Variable*.
3. Choose *(form, pers) InitialCommand*.
4. Click the *Edit* button.
5. Type the command of your choice: New, Refresh or FilterInPlace.
6. Click *OK* and then *Done*.
7. Exit Edit Mode.
8. Close the form.
9. Click *Yes* to save the changes.

**NOTE**

Depending on your form editing permissions you may or may not be able to do this globally, for a group or another user.
What are other personalization options?

There are many things you can do with SyteLine personalization. Here are just a few:

• Publish a form to the web
• Add a field
• Attach an action to a field
• Add a tab with fields

For more information, see the Personalization training guide or class.
**Wrap up: make job aids**

The best way to remember the various options you've learned in the class is to make some job aids and refer to them while you perform your day-to-day tasks. Take some time now to create your job aids. We suggest you choose one of the following methods.

**Tab this training guide**
1. Identify the sections of this book you're most likely to use (don't forget to look at the preface which includes a list of hotkeys).
2. Take a block of Post-It notes or other similar tabbing devices.
3. Write a reference on the tabbing device and place it on the appropriate page.
4. Keep the training guide close to your work area.

**Create cheat sheets**
1. Identify the tasks in this book you’re most likely to perform (don’t forget to look at the preface which includes a list of hotkeys).
2. Take a piece of paper or open a new document on your computer.
3. Summarize each task and steps or key-strokes for that task in the document. Add the page number in the training guide where you’ll find the full explanation.
4. Keep the document close to your work area.